消息关闭
    暂无新消息!

如上图所示,我也把JDK设置为1.8也不行,都会显示这个错误,Error:Gradle 3.1-rc-1 requires Java 7 or later to run. You are currently using Java 6.  求教,谢谢

7个回答

︿ 3
project structure里面把当前项目的jdk版本改了吗,可能你没改项目引用的jdk版本
︿ 2
原文不详,http://www.she.vc/article/18-98390-0.html
解决办法:
搜索之后了解到AS会自己设置默认的jdk位置,需要修改/Application/Android Studio/Contents/info.plist中

<key>JVMVersion</key> <string>1.8.0_92</string>
AS默认的是:

<key>JVMVersion</key> <string>1.6*,1.7+</string>
︿ 1
打开project structure,看一下compatibility的版本
找不到可以对照一下这个
http://blog.sina.com.cn/s/blog_77d5a0310102vhw1.html
︿ 1
急 急  整了一下午了  ,一点进度也没有 ,网上各种搜索 ,也没有想要的答案   ,请大神给解决方案,谢谢
︿ 0
1. Settings(File->Settings)
2. Build, Excution, Deployment(左侧菜单内)
3. Build Tools(左侧菜单内)
4. Gradle(左侧菜单内)
5. Gradle JVM(右侧详细设置界面内)